chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I'm getting this error when I try to run the tests using NCrunch, but they run with out errors if I just run them without NCrunch:
*** Typemock Isolator is currently disabled. Enable using the following:
 * Within Visual Studio: 
   - Use Typemock Smart Runner  
   - For other runners, Choose Typemock Menu and click "Integrate with Other Runners"
 * To run Typemock Isolator as part of an automated process you can:
    - run tests via TMockRunner.exe command line tool
    - use 'TypeMockStart' tasks for MSBuild or NAnt
For more information consult the documentation (see 'Running Unit Tests in an Automated Build')
   at TypeMock.InterceptorsWrapper.VerifyInterceptorsIsLoaded()
   at _o5NtKPKBqjpK2bca2sSrdbWge9t_._oEVqK2sNvaVRxKTchvwFj5JouMq_._vEe0Eg4rD42QZEmXdUs2Gqo0EQC_()
   at TypeMock.MockManager.Init(Boolean collectAllCalls)
   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_._8P6OirTYMwcdVWOmCbp00BddeWc_[](Members , Constructor , Constructor , Type , Object[] )
   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_.Instance[T](Members behavior)
   at _3qYkTLMWTAlbjHapXrg376QjqFI_._LdOrBrli6Ihgi9rHoQihjJtkBCi_.Instance[T]()
   at Libraries.Test.TestBase..ctor() in ..LibrariesTestTestBase.cs:line 192

How to fix this?
asked by dottzi (1.6k points)

1 Answer

0 votes

In order to solve your problem i need some information:

Where are you running your test?

Have you tried the suggestion from the exception to integrating NCrunch and Typemock?

Which NCrunch and Typemock versions do you have?


answered by Daniel (1.3k points)

The tests are run using ncrunch.

Yes, I tried to select "Integrate with Other Runners" but I still get the same response

We are using version of Typemock and version 2.19 og Ncrunch


Hi dotzi,

As we discussed with you and NCrunch support, it's a bug of the earlier Typemock version.

You better update Typemock to the latest version
Is this a bug that i specific to vs2015? Because I am able to run typemock and ncrunch with those versions on vs2013
Is this bug supposed to be fixed in typemock v8.3?
I would recommend  8.4 version if you want to keep it as low as possible