chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
When using the MSI to install Typemock with the silent option it doesn\'t add the Visual Studio integration (Typemock doesn\'t show in the menu). Doing a normal install does add the integration.

We\\\'re using TypeMock and the latest version of Visual Studio 2017.
asked by WouterDeKort (600 points)

1 Answer

0 votes
Hi Wouter

It\'s a bug, We are working on it.
The workaround I can suggest for now is to copy Typemock extension folder
and paste it after silent installation manually.

It is located in C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Professional\\Common7\\IDE\\Extensions\\Typemock\\Typemock Extension\\8.7

I will update you once it is solved.
answered by David (1.9k points)
This doesn\'t seem to work. We\'ve copied the folder to a machine missing the extension and it doesn\'t show up. We\'ve deleted the folder on a machine that did show the extension and it\'s still visible.

Anything else we need to do?

Hi WouterDeKort,

Try to do the following (after copying the folder):

- Close all instances of VS
-Open Developer Command Prompt for VS 2017 as an admin
- Run the command: devenv /Setup
- Wait until it finishes
Open VS again. Is the extension still missing?
Hi Wouter,

A patch was sent to you via the ticket system regarding this issue.

Let me know if it works

What about TypeMock 8.6?

We cannot get the TypeMock menu to show in Visual Studio 2017 Enterprise, nor can we get VS to run our tests.

The automated test process  (registering/unregistering TypeMock) is working fine.

We have copied the TypeMock/Typemock Extension folder into Microsoft Visual Studio\\2017\\Enterprise\\Common7\\IDE\\CommonExtensions, but without luck.

Have you tried doing the following?

1. Copying the Typemock folder to the VS2017 extensions folder.
2.Opening Developer Command Prompt For Visual Studio 2017 as admin.
3. Running devenv /setup.
Copying the folder and running the command in an elevated dev prompt unfortunately did not help.

I copied the Typemock folder to:

C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Enterprise\\Common7\\IDE\\Extensions


C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Enterprise\\Common7\\IDE\\CommonExtensions

Then I ran the command devenv /setup as admin, but no menu shows up.

Installing 8.7 and Typemock immediately shows up, but 8.6 does not.

Typemock 8.6 shows up in VS2012 and VS2013.

Thanks for helping me
I assume Isolator 8.7 and 8.6 are blocking each other in some kind of way.
Can you try removing both of the versions and then retry installation with the one you will work with?